1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, UCS 0.7.4.0 is now available. Get it now for FREE here
    Dismiss Notice
  3. Hi there Guest ! Are you a uploader and you are looking for a way to earn from your uploads? uploadify is a file hosting platform that provides you the possibility to earn from your download without the annoying surveys. Free 10 Gb Space!
    Dismiss Notice
  4. Hey Guest, It is hard to setup a server, that is why there is a documentation to help you here
    Dismiss Notice

Debugging libg.so

Discussion in 'Clash of Clans Underground' started by Ultrapowa, Sep 22, 2014.

  1. Anyone succeeded debugging libg.so?
    If so, did you learn something useful?
     
  2. I tried but I get many errors. Have you tried?
     
  3. Yes it worked using IDA Pro, android_server and my old rooted Galaxy S2.
    I also tried with BlueStacks but it doesn't work (can't attach process).

    It's very useful because you can access memory registers (r1, r2, ...) values and reproduce calculations.
    I think it's almost impossible to understand the en/decryption key update process without debugging.
     
  4. After hours of researching, I still don't manage to debug libg.so.
    Pushed android_server to my rooted device, installed ~3 different IDA Versions, still gives me this annoying message:
    "Check ur parameters u fegit"

    Need to talk to you asap.
     
  5. Did you ever manage to get this to work?

    If I try to step through with a debugger, I get SIGILL and SIGTRAP signals immediately followed by an app crash (with both IDA and gdb). I'm able to pause and continue execution without issue, but haven't been able to successfully set a breakpoint.
     
  6. Yes, what I do is:
    - I use a rooted phone with Android
    - Launch CoC and redirect trafic to local proxy
    - Proxy blocks first packet for 15s, while that time attach IDA debugger to CoC process
    - First packet is released, both IDA and CoC should run normally, and you should be able to reach your breakpoints
     
    Float likes this.
  7. Could you make an Video or something Ultra?
     
  8. Do you know if remote debugging works for apps running in BlueStacks? When you debug are you looking at ARM instructions
     
  9. I was not able to debug with BlueStacks, only with a real device
    I debug IDA generated pseudo-code more than ARM instructions except on very specific cases (like plugin bugs)
     
  10. I may be wrong but I don't believe IDA support debugging a file in ELF format from a remote machine running x86 (which is what most of the android emulators are). I believe Google's emulator is similar to a real phone (ELF on ARM) which is what you are doing (and IDA supports). Meh... I was hoping I could get this working in the Ganymede emulator and remote debug but now I'm skeptic. Any suggestions are very welcomed.
     
  11. Ultrapowa please go online on Skype:D
     
  12. I figured it out. Attached remotely to ganymede emulator.
     
  13. Hi can you please help me decrypt sc files
     
  14. Has anyone tried their hand at using radare2 to debug the native code on an android device/emu?
    Don't feel like paying for/pirating an IDA license. Regardless, I'll try next weekend if I have time.
     

Share This Page