1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, UCS 0.7.4.0 is now available. Get it now for FREE here
    Dismiss Notice
  3. Hi there Guest ! Are you a uploader and you are looking for a way to earn from your uploads? uploadify is a file hosting platform that provides you the possibility to earn from your download without the annoying surveys. Free 10 Gb Space!
    Dismiss Notice
  4. Hey Guest, It is hard to setup a server, that is why there is a documentation to help you here
    Dismiss Notice

HELP Internet Protocol Address

Discussion in 'Support' started by Furzi, Mar 8, 2017.

  1. Hello people, so I am done setting up the server hosted via dedicated machine. But there is a little problem. The IP it is trying to connect to is not the correct one. There are two IP's in my machine, one for public and one for private. The UCS.exe is connecting to the private one that it argues about it(See the picture). Is there any way for me to alter the IP it is trying to connect to? Thank you so much!
     

    Attached Files:

  2. please check your vps firewall and you need connect to public ip
     
  3. Hi there, you probably did not get what I am telling or is that you did not read very well. The thing is that, even if I turn off the firewall there is no way to change the IP the UCS.exe is reading from. "Maybe it is good to have a feature maybe just in the config to change the IP it should read and the port it wants to be connected to". I hope developers can read this, please.
     
  4. You said UCS didn't connect to correct ip :|
    UCS does not connect to any IP !!! The ip you seen in ucs console is one of your server ip's. UCS create a socket on 0.0.0.0:9339 it mean's you can connect to ucs with any public ip your vps have.

    Technical Info : https://msdn.microsoft.com/en-us/library/system.net.ipaddress.any(v=vs.110).aspx
     
  5. So the second line from the bottom is false then? "TCP Gateway started at 172.x.x.104:9339" -> is not real? Then why it is opening a port from that said IP?

    Also the UCS is opening the port in my 'private' IP and I cannot alter the UCS to connect and open the port to my public IP instead. That is the problem.
     
  6. #6 nameless, Mar 9, 2017
    Last edited: Mar 9, 2017
    "Also the UCS is opening the port in my 'private' IP and I cannot alter the UCS to connect and open the port to my public IP instead. That is the problem."
    the 'private ip' is in this case correct.
    u can see this in the source code:
    IPAddress ipAddress = Dns.Resolve(Dns.GetHostName()).AddressList[0];
    Logger.Say("TCP Gateway started at " + ipAddress + ":" + ipEndPoint.Port);
    in your local subnet this should always resolve to the 'private ip' (dns request for the url from the "outside" should get the 'public ip')
    However, as @moien007 already told u, the server is not "connected" to this ip, it will accept connections from any ip.
    Socket.Bind(new IPEndPoint(IPAddress.Any, port));

    If u really want to change that (wont have any effect besides the public ip in the log message) u could edit the hosts file or the sourcecode.
    However i would not recommend that, its pretty useless and if u have no idea what u are doing it can be dangerous.
     
  7. I do know everything I am doing and you still did not get it :( Let me explain it again for you sir.

    "I have 2 IP, mainly public and private. Private IP is my ipv4. But my public is different and is not my ipv4. Port 9339 is being opened with my private IP in which is not accessable externally ofc."
     
  8. "Port 9339 is being opened with my private IP"
    You dont open a port with an ip.
    Socket.Bind(new IPEndPoint(IPAddress.Any, port));
    As u can see the bind methode doesnt get your private or public ip as parameter ...
    If u cant access the port from outside u should check firewall settings etc. again.
     
  9. WHEN UCS CONNECT TO YOUR PRIVATE IP YOU CAN CONNECT VIA YOUR PUBLIC IP TOO, TEST IT

    (Sorry guys ucs didn't connect to any ip, just for explain he)
     
  10. You both are wrong, first of with nameless: Dude, when you open a server there has to be a port being opened for the said app. Port 9339 is what the UCS is using and it has to be opened accordingly. The problem with mine is that the ucs reads my private ip instead of the public one. Firewall settings are fine.

    Moien: You are so wrong too, that is why it is 'private' because you cannot use it for external hosting. There are 2 ip that I said. Private and public. You cannot use your private ip with the port being opened and connect to the public ip with that port. That is just so wrong and is not possible.
     
  11. "Dude, when you open a server there has to be a port being opened for the said app."
    i know that ... and i showed u the part of the source code where ucs opens the port ... but u still dont need an ip to open the port ... the port is not connected to your private or public ip or only open on the private or the public ip (only if the firewall settings are wrong)
    Here u go again:
    Socket.Bind(new IPEndPoint(IPAddress.Any, port));
    (still no ip and only the port number)

    Anyway, have u tried UCS 0.7.3? Does this version fix the problem?
     
  12. 7.3.0 does fixed the problem as it is opening the port with the ip 0.0.0.0:9339. The ip reading from the 7.2.1 was different from the one you have. It might be from the older version of ucs :)
     
  13. Well i am glad it works now
    However it was only an error in the log output of the server ... in the backgroud it was always '0.0.0.0'
    Socket.Bind(new IPEndPoint(IPAddress.Any, port));
    IPAddress.Any represents 0.0.0.0 in this case (source: https://msdn.microsoft.com/en-us/library/system.net.ipaddress.any(v=vs.110).aspx "The Any field is equivalent to 0.0.0.0 in dotted-quad notation.")
    So it in versions below 0.7.3 it was also 0.0.0.0
     
    Furzi likes this.
  14. @Furzi In simple english, UCS Create Server On All Your Server IP's and The IP Your Seen in UCS Screen is One of Your Server IP's.
    I can't explain you anymore and i think i'm wasting my time on your problem.

    I hope you explained and thanks to @nameless for...
     
  15. I am sorry, but you were really wrong. Anyways, is there no more problem about the latest apk file being released? For decompilation?
     
  16. works fine for me:
    $> apktool d test.apk
    I: Using Apktool 2.0.3 on test.apk
    I: Loading resource table...
    I: Decoding AndroidManifest.xml with resources...
    I: Loading resource table from file: \framework\1.apk
    I: Regular manifest package...
    I: Decoding file-resources...
    I: Decoding values */* XMLs...
    I: Baksmaling classes.dex...
    I: Copying assets and libs...
    I: Copying unknown files...
    I: Copying original files...

    (renamed the downloaded oqxvsyb.apk (no idea why it has that name) to test.apk)
     

Share This Page